Released: NVidia driver 180.22 (x86) for FreeBSD

NVidia has announced the availability of the new 180.22 grapics drivers for FreeBSD.

Release Highlights:

  • Added support for the following GPUs:
    • Quadro FX 2700M
    • GeForce 9400M G
    • GeForce 9400M
    • GeForce 9800 GT
    • GeForce 8200M G
    • GeForce Go 7700
    • GeForce 9800M GTX
    • GeForce 9800M GT
    • GeForce 9800M GS
    • GeForce 9500 GT
    • GeForce 9700M GT
    • GeForce 9650M GT
    • GeForce 9500 GT
  • Added initial support for PureVideo-like features via the new VDPAU API (see the vdpau.h header file installed with the driver).
  • Added preliminary support for OpenGL 3.0.
  • Added new OpenGL workstation performance optimizations.
  • Enabled the glyph cache by default and extended its support to all supported GPUs.
  • Disabled shared memory X pixmaps by default; see the “AllowSHMPixmaps” option.
  • Improved X pixmap placement on GeForce 8 series and later GPUs.
  • Improved stability on some GeForce 8 series and newer GPUs.
  • Fixed a regression that could result in window decoration corruption when running Compiz using Geforce 6 and 7 series GPUs.
  • Fixed an nvidia-settings crash when xorg.conf contains Device and Screen sections but no ServerLayout section.
  • Fixed a problem parsing the monitor sync range X config file options.
  • Fixed a problem with the SDI sync skew controls in nvidia-settings.
  • Fixed a problem that caused some SDI applications to hang or crash.
  • Added support for SDI full-range color.

Note that the gtk-2.x ports package(s) shipped with FreeBSD releases > 5.3-RELEASE are binary incompatible with those shipped with FreeBSD 5.3-RELEASE; due to this, the `nvidia-settings` binary shipped with 180.22 will not work on FreeBSD > 5.3-RELEASE. This problem can be solved by (re-)building `nvidia-settings` from source:


# fetch ftp://download.nvidia.com/XFree86/nv…-180.22.tar.gz
# tar zxf nvidia-settings-180.22.tar.gz
# cd nvidia-settings-1.0# gmake
# install nvidia-settings /usr/X11R6/bin

Download driver | Readme & Installation Guide  

Source: nvidia.com (08/01/2009)

3 thoughts on “Released: NVidia driver 180.22 (x86) for FreeBSD

  1. Geraud says:

    I still find it completely moronic that they require compat5x. 5.x has been EOL’d for quite some time now, 6.4 should be the last in the branch. Also if you try to build anything against OpenGL once the driver is installed you’ll see a lot of warnings (at best, failures otherwise) about libs version mismatch.

    If you count this and the lack of support for x64 platforms (yes I know, they’re waiting for FreeBSD people to give them linux-like access to memory so their code suddenly becomes “portable”), I think it’s the last time I’ll get an NVidia card. I’ve been an avid fanboy for years, but I guess I’ll switch to ATI or Intel for my next hardware upgrade.

    Geraud’s $0.02

  2. Dave says:

    I’ve been running this driver for a couple of weeks now. It’s been very well behaved and stable, I usually jump on the beta driver releases to give some feedback and the entire 180.xx series of beta drivers were horrific. Memory leaks and X crashes were fairly common. But this non-beta release has been great.

    Compat5 is not actually required for installing these. I’m running FreeBSD 7.0 without any issues. The only pain with installing these drivers are that the nvidia-settings app that comes with the actual driver download is usually out of date and you have to grab the newer version and compile it yourself. (This is noted in the release notes).

    As much hate as there is on the Nvidia FreeBSD forum for them not having 64-bit drivers, we’ve at least got to be thankful that they are actually releasing up to date drivers for us at all. All my FreeBSD boxes have Nvidia cards in them.

  3. kace says:

    Having support at all for FreeBSD is a great thing. And, updates, too! Incredible. As of now, I’m still in the bag for Nvidia, due primarily to their BSD support.

    I sure hope they’ll get the 64-bit support worked out soon, though. Also, very nice would be Cuda support for FreeBSD!! (See http://www.nvidia.com/object/cuda_what_is.html )

    Regarding the other graphics vendors, have there been some new developments? Wouldn’t you lose HW acceleration using Ati or Intel graphics under FreeBSD?

Leave a Reply

Your email address will not be published. Required fields are marked *

You may use these HTML tags and attributes: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <strike> <strong>